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Purpose

Document structure with OpenOffice Writer

This tutorial will show you how to add proper structure 
your documents.

Document structure includes:

▸ Section or chapter headings

▸ Page headers/footers

▸ Distinct page layouts in each part of the document



  

A structured document

Document structure with OpenOffice Writer

Title page
No footer
No page #

ToC
Made from 
outline 
headings

ToC page
Footer with 
Roman page 1

Body text
Starts new page
Numbered outline 
headings

Body page
Footer shows 
chapter number, 
Arabic page 1



  

How to use this tutorial

Document structure with OpenOffice Writer

➔View these instructions in a window

➔Open the sample document in a separate Writer 
window

File > Open > File name: simple_sample.ott

➔Adjust the windows on your computer screen so that 
both are visible and accessible

➔Follow the steps, working in the Writer document

Steps to follow are marked with colored arrows

simple_sample.ott


  

How to use this tutorial

Document structure with OpenOffice Writer

▸ The sample document is a template document. When 
you open a template you get a new, untitled document 
to work with: any changes go into the new document.

▸ You can save your modified sample document at any 
point
● To pick up again later: re-open your saved document

● To start over:open the “simple_sample” template

▸ The sample text consists of several headings (normal 
black text), along with jumbled filler text (colored).



  

Before you begin

Document structure with OpenOffice Writer

The steps given here are dependable and will help you 
understand how Writer handles document structure.

Writer provides alternative shortcuts for some of the 
tasks presented here. In some situations, the shortcuts 
may not work or may give unexpected results.

If you invest the time to understand how Writer works, 
you can apply that knowledge to any situation, and you'll 
be ready when the shortcut takes you somewhere you 
weren't expecting.



  

Document outline headings

Document structure with OpenOffice Writer

▸ Outline headings organize the document content by 
dividing it into specific, logical parts

▸ Outline headings are regular text paragraphs

▸ A paragraph is marked as a heading when you apply 
a specific paragraph style

▸ Writer uses the style named Heading 1 for top-level 
headings. These are usually the section or chapter 
titles



  

Step by step

Document structure / Document outline headings

➔Move the editing cursor to a heading paragraph

Click in the first heading: ►The first part

➔Apply the heading style

Locate the paragraph style Heading 1 in the Styles & 
Formatting window (F11)

Double-click the style name to apply that style

➔Repeat for each following heading



  

When formatting the document headings …

▸ Do apply the proper heading style

▸ Don't use manual formatting

This will ensure that the headings are

━ Formatted consistently

━ Included in the document outline and Table of Contents

━ Available in Writer's Navigator window (F5)

Remember:

Document structure with OpenOffice Writer



  

Add a table of contents

Document structure / Document outline headings

▸ Once the document has proper outline headings, Writer 
can build a Table of Contents from them



  

Step by step

Document structure / Add table of contents

➔Move to the beginning of the sample document

➔Select the text: Table of Contents

➔Insert the index

Insert > Indexes and Tables > Indexes and Tables >
Type: Table of Contents

Click OK



  

Add outline numbering

Document structure / Document outline

▸ Writer can number the outline headings for you

▸ This will save time when you need to:

━ re-organize or change the order of your document

━ display the chapter number in page footers/headers

━ cross-reference the outline headings in the document text



  

Step by step

Document outline / Add numbering

➔Configure numbering for the outline headings

Tools > Outline Numbering > Numbering

Level: 1

Paragraph style: Heading 1

Number: A, B, C …

Click OK

➔Verify: each heading should now be labeled: A, B, C

Note: The ToC will not automatically pick up the numbering 
change; we're going to address this later.



  

Add a title

Document structure with OpenOffice Writer

▸ If you want Writer to track the document title, you must 
enter it as a document property

▸ This will be helpful when you need to display the 
document title within the document itself



  

Step by step

Document outline / Add a title

➔Edit the document properties

File > Properties > Description > Title: A Simple Sample

Click OK

➔Display the title property in the document

Move to the start of the sample document

Select the text Document Title

Insert > Fields > Title

➔Format the title

Apply the paragraph style: Title



  

▸ Despite what you see on the screen, Writer does not 
work with pages of text.
It works with a sequence of paragraphs.

▸ While you can select text and apply formatting to it, 
you can't select a page because …

… there are no pages, only paragraphs

Page layout and numbering

Document structure with OpenOffice Writer



  

▸ The paragraphs flow into pages which are laid out 
according to settings stored in a specific page style.

▸ A separate page style is needed for each different 
page layout in the document

▸ The sample document has three distinct page layouts:
● Title page: no header or footer, no page numbers

● Front page: page footer with page number only

● Body text: complete page footer

Page layout and numbering

Document structure with OpenOffice Writer



  

Add page styles

Document structure / Page layout and numbering

▸ We need to create a separate page style for each 
distinct page layout:

Document part /
Page layout area Page style name

Title page: >Title page

Front matter pages: >Front matter

Body text pages: >Body text

The > is just a character in the style name. It helps to distinguish 
our custom page styles from the built-in style names.



  

Step by step

… / Page layout and numbering / Add page styles

➔Create the >Body text page style:

Open the Styles & Formatting window (F11)

Select the page style category (buttons left/above style list)

The rightmost button in the row above the style list is a menu. 
Click it and choose:

New style from selection

Enter the page style name: >Body text

Click OK



  

Add page styles

Document structure / Page layout and numbering

▸ The other two page styles

>Title page

>Front matter

have already been created for you.

▸ They are stored in the template, ready to use



  

▸ Once you have a full set of page styles, you can 
assign those styles to take effect at specific points in 
the text. Those specific points are page breaks

▸ A page break is a property assigned to a paragraph

▸ We will add a page break to specific paragraphs

Each page break will specify a page style to take effect on the 
page that starts with that paragraph

The page break may also reset the page numbering

Page layout and numbering

Document structure with OpenOffice Writer



  

▸ Writer dynamically flows paragraphs into pages. 
When it comes to a paragraph with a page break, 
several important things happen:

━ A new page begins: the paragraph will start at the top of the 
new page

━ The new page style, as specified in the page break, takes 
effect for the new page

━ The page number assigned to the new page takes effect

Page layout and numbering

Document structure with OpenOffice Writer



  

▸ We can show this relationship in a diagram:

━ The text paragraph properties include a page break

━ The page break calls for a page style named >Title page

━ The page style tells how to lay out and format the new page

Page layout and numbering

Document structure with OpenOffice Writer

Formatting properties
Page break

with page style: >Title page
Page number: 1

Text paragraph

Layout properties
page size, margins
page number format

Header & footer
on/off: ON
page number format: 
small roman numerals

Page style: >Title page



  

▸ There are three places in the document where we 
want to start using a particular page layout:

━ The title page

━ The table of contents

━ The the first outline heading
(the beginning of the document body text)

▸ A page break is needed at each place in order to call 
for a new page style

Add page breaks

Document structure with OpenOffice Writer



  

▸ Remember: page breaks …

━ are actually paragraph properties

━ are part of the first paragraph on the new page

▸ Note: the title page may still have a page break even 
though it appears on the first page of the document

Add page breaks

Document structure with OpenOffice Writer



  

Step by step

Page Layout / Add page breaks / Body text

➔Add a page break for the body text pages

Work from the back of the document: it's easier to follow

Click in the first outline heading: ►The first part

Format > Paragraph > Text Flow > Breaks >

● Insert: YES (checked)

● Type: Page

● With page style: >Body text

● Page number: 1

Click OK



  

Step by step

Page Layout / Add page breaks / Front matter

➔Add a page break for the front matter page

Click in the ToC heading:   Table of Contents

Right-click > Edit Paragraph Style > Text Flow > Breaks >

Verify style name (window title): Contents Heading

● Insert: YES (checked)

● Type: Page

● With page style: >Front matter

● Page number: 1

Click OK



  

Step by step

Page Layout / Add page breaks / Front matter

Note:

The Table of Contents is a protected index area and can't be 
changed directly by Format > Paragraph

Instead, we add the page break to the paragraph style for the 
heading paragraph

When a paragraph style has a page break+page style, the page 
layout change will apply to every paragraph that uses that style. 
In this case, there is only one instance of the Contents Heading 
style.



  

Step by step

Page Layout / Add page breaks / Title page

➔Add a page break for the title page

Click into the title paragraph

Format > Paragraph > Text Flow > Breaks >

● Insert: YES (checked)

● Type: Page

● With page style: >Title page

● Page number: 0 *

Click OK

* Zero here means “continue with the current page numbering”. In this case you could enter zero or 
one, as this is the first page … or any other number since no page number appears on this page!



  

▸ We've finished adding the three page breaks that 
begin the three distinct page layouts

▸ Each page break tells Writer ...

━ start a new page

━ lay out the new page according to a specific page style

━ use a specific page number for the new page

▸ The page style in effect for the current page is shown 
in the status bar below the editing area

Review

Document structure / Page layout and numbering



  

Review

Document structure with OpenOffice Writer

The sample document should 
now look something like this:



  

▸ Page styles store settings and content that affect 
page layout

▸ Each page style includes:

━ page size and margins

━ header and footer layout

━ header and footer content

━ page number format

▸ With the page breaks now in place and linked to the 
correct page styles, we can now configure each page 
style to produce the desired page layout

Configure page styles

Document structure with OpenOffice Writer



  

▸ The layout and content of a page footer or header are 
properties of the page style

▸ For each page style that requires it, we will need to 
add the footer layout area, and …

▸ Add content for each distinct footer:

━ Front matter: a bare page number, as roman numeral

━ Body text pages: Section X, page N

Add a footer

Document structure / Page layout / Page styles



  

Step by step

Page style / Add footer / Front matter

➔Click in the ToC page but not in the shaded ToC area

Right-click > Page > Footer > Footer

● Verify the page style (window title): >Front matter

● Footer on: YES (checked)

Click OK

➔Verify: the ToC page should have an empty footer 
area

➔Verify: other pages should not (yet) have a footer 
area



  

Step by step

Page style / Add footer / Body text

➔Click anywhere in a body text page

Right-click > Page > Footer > Footer >

● Verify the page style (window title): >Body text

● Footer on: YES

Click OK

➔Verify: the body pages should all have an empty 
footer area

➔Verify: the title page should not have a footer area



  

▸ We've added the footer areas to the page styles for 
the front matter and body pages

▸ Now, we add the content for each footer:

━ Front matter: bare page number, as roman numeral

━ Body text pages: Section X, page N

▸ Remember: even though it appears to be part of the 
text page, the footer content belongs to the page style

Add footer content

Document structure / Page layout / Page styles



  

Step by step

Page style / Add footer content / Front matter

➔Click in the footer area of the ToC page

Verify the page style in the status bar: >Front matter

Type: Tab (move to center)

Insert > Fields > Page Number

➔Verify: the ToC page should have a number: 1

➔Verify: no other page should have a page number



  

Step by step

Add footer content / Front matter / Number format

➔Click in the ToC Page (not in the shaded ToC area)

Right-click > Page > Page > Layout settings >

● Verify the page style name (window title): >Front matter

● Page layout: Right and Left

● Number format: i, ii, iii, …

Click OK

➔Verify: the page number should display as: i

➔Verify: other pages should not (yet) show a page 
number



  

Step by step

Add footer content / Front matter / Number format

Note:

If you double-click on the page number field, you get a 
dialog window that allows you to set a number format 
and an offset:

These settings are not what you want

These settings apply to this specific instance of the field and not 
to the page style. They may look correct initially but they won't 
integrate with the rest of the document, which works with settings 
in the page style.



  

Step by step

Page style / Add footer content / Body text

➔Click in the footer area of any body page

Verify: page style name (status bar): >Body text

Type: Tab (to center), then type: Section X, Page N

➔Verify: all body pages should show the footer content

➔Add information fields in place of static text:

Select the character: N

Insert > Fields > Page Number

➔Verify: all body pages should display a page number 
in the footer



  

Step by step

Page style / Add footer content / Chapter number

➔Click in the footer area of any body page
Verify: page style name in the status bar: >Body text

Verify: the footer should already have: Section X, Page #

➔Add a chapter field in place of static text
Select the character: X

Insert > Fields > Other > Document
● Type: Chapter
● Format: Chapter number without separator

Click Insert then Close

➔Verify: all body pages should display both chapter 
and page number in the footer



  

Update the document

Document structure with OpenOffice Writer

Some document information may not update 
automatically as changes are made. You can explicitly 
tell Writer to update the document as required.

➔Update the Table of Contents

Click anywhere in the shaded ToC area

Right-click > Update Index/Table

➔Or, update the whole document

Tools > Update > Update all

Note: this updates the ToC and other indexes as well



  

▸ We've finished with the structure and page layout of 
the sample document, including

━ Section or chapter headings

━ Table of Contents

━ Page headers/footers

━ Distinct page layouts in each part of the document

Review

Document structure with OpenOffice Writer



  

Review

Document structure with OpenOffice Writer

Title page
No footer
No page #

ToC
Made from 
outline 
headings

ToC page
Footer with 
Roman page 1

Body text
Starts new page
Numbered outline 
headings

Body page
Footer shows 
chapter number, 
Arabic page 1

Here's another look at the final document:



  

Writer includes many convenient shortcuts for common 
tasks. These alternative pathways carry out the same 
operations shown in the tutorial but they may have 
other effects.

You should be familiar with the dependable steps 
shown in the tutorial, and understand how they work, 
before you move on to use the shortcuts.

Shortcuts

Document structure with OpenOffice Writer



  

Writer's default configuration includes several keyboard 
shortcuts for applying a heading style:

For a … Press to apply style

Level 1 (top) Ctrl+1 Heading 1

Level 2 Ctrl+2 Heading 2

Level 3 Ctrl+3 Heading 3

Level 4 Ctrl+4 Heading 4

Level 5 Ctrl+5 Heading 5

You can also use Tab and Shift+Tab to change a heading 
paragraph's outline level and heading style.

Apply a document heading style

Document structure with OO Writer: Shortcuts



  

In this tutorial, we added page breaks as a paragraph 
formatting property; this is the way page breaks are 
stored in the document.

Writer has a shortcut menu for adding a page break:
▸ Insert > Manual Break …

━ Type: Page Break

━ Style: (optional page style)

━ Page number: (optional page number change)

This menu does exactly the same thing as Format > Paragraph: 
it adds the page break property to the current paragraph.
It does not actually “insert” anything.

Add a page break

Document structure with OO Writer: Shortcuts



  

This tutorial shows how page styles are applied as part 
of manual page breaks attached to text paragraphs.

Writer provides two shortcuts for applying a page style:
▸ Status bar pop-up menu

━ Right-click the page style name in the status bar

━ Select the page style from the pop-up menu

▸ Styles & Formatting window
━ Double-click the page style name

However … these shortcuts should only be used to 
change which page styles are used and not to define 
what pages use which page style. Because …

Apply a page style

Document structure with OO Writer: Shortcuts



  

… both of these shortcuts may produce surprising 
results when the document does not already contain 
the necessary page breaks:

▸ The page style may take effect at an earlier page 
than appears on the screen, and it may affect many 
pages, or the whole document!

Remember: you can't apply a page style to the pages 
you see on the screen the same way you apply 
formatting to selected text—there are no pages.

Apply a page style

Document structure with OO Writer: Shortcuts



  

A page style can only take effect where a text 
paragraph has a page break+page style property. 
When you use a shortcut to apply a page style, Writer 
searches back to the nearest paragraph with such a 
property, and that's where the page style will take 
effect.

If no eligible paragraph is found, the page style will take 
effect at the start of the document; if there is no page 
break+page style following, the page style will apply to 
the whole document!

Apply a page style

Document structure with OO Writer: Shortcuts



  

That's all for now …

Document structure with OpenOffice Writer
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