Brak opcji funkcje w widoku kwerendy

Użytkowanie programu bazodanowego
fairhair
Posty: 2
Rejestracja: sob cze 25, 2022 3:02 pm

Brak opcji funkcje w widoku kwerendy

Post autor: fairhair »

Witam, to mój pierwszy post na forum. Kiedyś korzystałem z programu Microsoft Access i tam bazy danych świetnie mi szły. Odkąd używam LibraOffice Base to mam problemy. Nie wyświetlają mi się żadne opcje w polu funkcje w widoku kwerendy. I to zarówno gdy baza jest w pliku xlsx jak i dbase. W accesie zawsze były suma, różnica, policz, minimum, maksimum i td, Tu pisze brak funkcji. Oglądałem wiele tutoriali na youtube i nie znalazłem żadnej wskazówki. Będę wdzięczny za wszelką pomoc
Libra Office 7.3, Windows 10
Awatar użytkownika
Rafkus
Posty: 419
Rejestracja: czw kwie 12, 2018 10:26 pm

Re: Brak opcji funkcje w widoku kwerendy

Post autor: Rafkus »

Takie coś się dzieje gdy źródłem danych jest plik arkusza kalkulacyjnego.
Rozwiązanie: utwórz nową bazę danych a następnie skopiuj dane z arkusza i wklej je do Tabel w bazie. W ten sposób sposób kwerendy będą miały wymagane funkcje ale niestety, nie będziesz miał automatycznej aktualizacji danych w bazie, w przypadku dopisania jakiś kolejnych wartości w wierszach arkusza.

Innym rozwiązaniem może być powiazanie pliku tekstowego (.txt lub .csv) z twoja bazą danych.
https://wiki.documentfoundation.org/Faq/Base/143
UWAGA: Sam to niedawno znalazłem i dopiero się tym bawię, więc nie mogę powiedzieć czy będą jakieś inne komplikacje czy tez nie...
LibreOffice 7.1.6 (preferowany) oraz OpenOffice 4.1.6. Widows 10
OpenOffice 4.1.3. oraz Libre 4.2.5.2 Windows XP
fairhair
Posty: 2
Rejestracja: sob cze 25, 2022 3:02 pm

Re: Brak opcji funkcje w widoku kwerendy

Post autor: fairhair »

:arrow: Rafkus mega dzięki za podpowiedź. Swoją drogą przy dużych bazach danych lepiej kupić accessa a nie przeklejać masę danych z arkusza
Libra Office 7.3, Windows 10
Awatar użytkownika
Rafkus
Posty: 419
Rejestracja: czw kwie 12, 2018 10:26 pm

Re: Brak opcji funkcje w widoku kwerendy

Post autor: Rafkus »

Do moich potrzeb BASE jest wystarczające, choć nie przeczę czasami praca z nim wygląda tak: :ucrazy: :crazy: :knock: :ouch:
LibreOffice 7.1.6 (preferowany) oraz OpenOffice 4.1.6. Widows 10
OpenOffice 4.1.3. oraz Libre 4.2.5.2 Windows XP
ODPOWIEDZ