[Résolu][OXT] Sauvegarde auto avec incrément du nom

Discussions sur les projets et applications développés en liaison avec une suite bureautique libre.

Modérateur : Vilains modOOs

Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
Messages : 1527
Inscription : 28 sept. 2008 14:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Alain de La Chaume »

Bonjour à tous,
J'ai fait l'effort de "travailler" ce dimanche, ça mérite à mon avis ce nouveau message à la date d'aujourd'hui :wink: .
Cette nouvelle version 1.0.4 comporte :
1. Une modification du paramètre envoyé à acGetIncrement qui devrait régler le problème constaté sous Windows.
2. Une modification dans acTraceSauve pour éviter qu'une trace écrase la précédente.
3. Une version unique, sans trace ou avec. Il suffit pour tracer de remplacer false par true, dans le module aMain :

Code : Tout sélectionner

  public const bTRACER = false	' Si bTRACER est vrai, tracer infos
Pièces jointes
incrSav-1.0.4.oxt
(13.38 Kio) Téléchargé 547 fois
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
Messages : 7610
Inscription : 18 oct. 2007 18:28

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Ravioli »

Bonjour Alain,

Superbe correctif !

Essayé sur Viceta :P
On peut donc désormais laisser les espaces dans le nom (ce qui reste quand même l'usage courant sous Microsoft Windows).

De plus, ce qui est fort bien c'est qu'une fois ouvert un des fichiers sauvegardés dans zzSauveIncr
exemple La nouvelle mouture_2.odt
Répertoire_n°1.png
et en relançant la sauvegarde incrémenté, un nouveau zzSauveIncr se crée dans le dossier précédant
et la numérotation repart en intégrant le nom origine La nouvelle mouture_2.odt.en La nouvelle mouture_2_0.odt.
Répertoire_n°2.png
:bravo: :bravo: :super:
Merci encore,
Ravioli.
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Sauvegarde avec incrémentation automatique

Message par CdChar »

Bonjour,

J'ai installé la dernière version de l'extension Sauvegarde avec incrémentation automatique proposée pour tous les modules, sur un fichier base ( 675 ko).
http://user.services.openoffice.org/fr/ ... 18&t=18566

J'ai des erreurs à l'exécution et les fichiers résultats crées ont 0 octets, quand ils sont créés, il m'a même fallu rétablir la base
J'ai suivi pas à pas la procédure d'installation.
L'erreur est "Action non supportée , appel de pocédure non valide" , sur la ligne:

Code : Tout sélectionner

selFin = instr(selDeb, bufTmp, ".")
de la fonction acGetIncrement(nomFic)

j'ai fait un test sur une autre base , tout a marché normalement.
le nom de la base qui pose problème: " bac1bentreprise.odb"
le dossier zzSauveIncr a été créé automatquement, j'ai testé avec un fichier d'origine présent ou non dans le dossier.

J'ai aussi une exception com.sun.star.package.zip.ZipIOException: the stream seems to be broken, et dans ce cas le fichier sauvegardé est de 0 octet

Ceci sous Windows XP

Merci pour votre aide.
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 11276
Inscription : 02 mai 2006 10:42

Re: Sauvegarde avec incrémentation automatique

Message par Pierre-Yves Samyn »

Bonjour

Puisqu'il semble s'agir d'un problème à l'exécution d'un programme il me semble que la question aurait davantage sa place dans la section macro du forum ?

Cela dit, le problème ne se pose que pour cette base ? Fonctionne-t-elle pour les autres types de document ?
Avatar de l’utilisateur
Bidouille
RespOOnsable forum
RespOOnsable forum
Messages : 11367
Inscription : 08 nov. 2005 18:23
Localisation : Caen, France
Contact :

Re: Sauvegarde avec incrémentation automatique

Message par Bidouille »

Bonjour,
Pierre-Yves Samyn a écrit :Puisqu'il semble s'agir d'un problème à l'exécution d'un programme il me semble que la question aurait davantage sa place dans la section macro du forum ?
Je dirais même plus : sa place à la suite dans la section Projet où il y a le fil dédié.

Vous pouvez continuer à poster à la suite de ce problème.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: Sauvegarde avec incrémentation automatique

Message par Dude »

Salut,
CdChar a écrit :j'ai fait un test sur une autre base , tout a marché normalement.
le nom de la base qui pose problème: " bac1bentreprise.odb"
Quelle taille fait la base ?
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,

La base fait 675 KB.
Je ferai des tests plus tard dans la journée, mais je me demande s'il ne pourrait pas y avoir un effet de bord avec le SWITCHBOARD qui démarre à l'ouverture de la base (macro utils.autoexec).
J'avais posté dans base parce que le fil d'origine a dans son entête [Tous] .

Merci
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

CdChar a écrit :mais je me demande s'il ne pourrait pas y avoir un effet de bord avec le SWITCHBOARD
A priori, je ne vois pas pourquoi. Essaye aussi de compresser ta base pour voir si le poids n'est pas en cause.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 11276
Inscription : 02 mai 2006 10:42

Re: Sauvegarde avec incrémentation automatique

Message par Pierre-Yves Samyn »

CdChar a écrit :j'ai fait un test sur une autre base , tout a marché normalement.
le nom de la base qui pose problème: " bac1bentreprise.odb"
J'ai testé avec une base portant ce nom sans rencontrer de problème.
Constatant que tu faisais précéder ce nom d'un espace (en principe automatiquement supprimé en début de nom) j'ai également testé avec ce nom précédé du caractère Alt+255, également sans problème.

Quelle version de l'extension utilises-tu ?
Par ailleurs tu n'as pas répondu à mon autre question : l'extension fonctionne-t-elle chez toi dans les autres modules ?
As-tu essayé avec un profil neuf (il faudra réinstaller l'extension) ?
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,
Je fais le test avec incrSav-1.0.4.oxt.
Je viens de faire un test sur une autre machine avec OOO 3.2.0

- même problème avec cette base, switchboard actif ou pas,
j'ai la ZipIOException sur la ligne

Code : Tout sélectionner

oDoc.storeToUrl(sUrl2, tArgs())
- pas de problème avec une base de 2496 KB

- j'avais aussi fait des tests en changeant de nom

Donc pas un problème d'installation, de profil, de taille, de nom
La solution serait de la joindre, mais son contenu n'est pas public, et je crois qu'elle est trop volumineuse.
Merci à vous
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Grenouille
ManitOOu
ManitOOu
Messages : 3223
Inscription : 13 janv. 2006 18:21
Localisation : Chasseneuil-du-Poitou / Futuroscope

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Grenouille »

Bonsoir,
OOo 3.2.1, Windows XP et Windows 7
L'OS est-il en cause ? Tu as testé sur les 2 ?

A+
OpenOffice 4.1.5 et LibreOffice 5.3.4 (par obligation) sous Windows 7
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [Résolu] [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,

Je viens de renommer mon fichier *.odb en *.zip je l'ai décompresse avec 7Zip.
qui me dit:
"Donnée erronée dans le fichier 'report\obj23\ObjectReplacements\report' Le fichier est corrompu"
Le fichier report. contient 0 octet
Je vais rechercher à quoi correspond obj23 en inspectant les fichiers xml, je suppose un report de SRB et éventuellement supprimer report\obj23

Cela pourrait bien expliquer le problème de zipException.
Cette base contient peut de données, surtout des formulaires et report.
Je vais suivre ce qui est dit dans:
http://user.services.openoffice.org/fr/ ... 09#p130009 concernant le cache graphique, cependant chez moi la valeur par défaut est 9 et non 20.

En regardant dans le fichier content.xml de report\obj23 je trouve:
<db:component db:name="R_Tp_motifVisite" xlink:href="reports/Obj23" db:as-template="false"/>

Je vais commencer par supprimer le report "R_Tp_motifVisite" de fichier odb, puis si nécessaire report\obj23

Un peu plus tard: Rapport supprimé , sauvegarde sans problème.
Conclusion: non seulement cet outil est très utile pour les sauvegardes, mais en plus il permet de détecter une corruption ignorée, car avant de supprimer le rapport, je l'ai testé, il fonctionnait parfaitement.

Merci à vous
Dernière modification par CdChar le 19 août 2010 09:33, modifié 2 fois.
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

As-tu fait ce que je te proposais ?
Dude a écrit :Essaye aussi de compresser ta base pour voir si le poids n'est pas en cause.
Cela peut régler peut-être le problème d'objet corrompu dans l'ODB.
CdChar a écrit :le cache graphique, cependant chez moi la valeur par défaut est 9 et non 20.
Déjà que la valeur par défaut est insuffisante. Sous quoi ?
Grenouille a écrit :Windows XP et Windows 7
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re:[Résolu] [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour Dude,

Ces tests je les ai faits sous XP, je n'ai pas dans l'immédiat accès à W7.
J'avais compressé la base avant de supprimer le rapport, sans effet.
Ton message et mes différentes MAJ du fil on dû se croiser, le problème est résolu en supprimant le rapport, heureusement très facile à reconstituer.
Je pratique la base OOO depuis 2006, je trouve l'outil encore plus sensible ces derniers temps ( sur des nouveaux documents).
Je vais commencer par augmenter la taille du cache graphique.

Merci à tous pour votre temps.
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

CdChar a écrit :je trouve l'outil encore plus sensible ces derniers temps ( sur des nouveaux documents).
Si ton cache graphique est aussi faible, cela me parait logique.

Concernant SRB, je tombe sur le rapport 111542 qui fait état d'une consommation en RAM inhabituelle (plus de 50 Mo) dans certains cas. Ceci explique peut être cela.

Bref, plus rien à voir avec l'extension de sauvegarde d'Alain. Si tu souhaites donc poursuivre le débat, ouvre un nouveau fil dans la section Base.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,
Pour l'instant je désactive l'option.
Hier à la suite du premier problème, je suis repartie d'une base propre.
Au cours de l'après midi , deux autres fichiers rapport ont été corrompus, sans que j'ouvre aucun rapport pour execution ou modification.
Je n'avais fait que modifier le source d'une macro et d'un formulaire pour y tester la macro .
Cette macro fait une requête sql pour modifier le contenu d'un contrôle de table.
Entre chaque modification j'avais exécuté une "sauvegarde auto", numérotée de 0 à 10.
Un plantage lors de la dernière, m'a fait m'inquiéter du contenu du fichier, le contrôle de l'archive avec 7Zip a montré deux fichiers META.XML sous /report corrompus.
J'ai donc remonté l'historique en chargeant les différentes bases obtenues par sauvegarde automatique, le premier fichier corrompu se retrouve dans la sauvegarde *_7, Le second dans la *_10.
Je joins un fichier zip, contenant l'état de l'objet obj62 à différents moments:
- Obj62_ko_base extrait de ma base lorsque je me suis rendue compte du problème noter la date de MAJ du fichier: 11/08/2010 du fichier meta.xml
- Obj62_ok_svg_incr extrait d'une sauvegarde automatique avant première corrupion, la *_6 , noter la date du fichier meta.xml, celle de la svg 19/08/2010
- Obj62_ok_2010_08_16_cpy_WXP extrait d'une sauvegarde classique par copier-coller sous Windows , fichier correct daté du 11/08/10 pour une sauvegarde faite le 16/08
Entre temps, j'avais modifier la taille du cache
Se passe sous WXP.

Merci pour votre temps
Pièces jointes
obj62.zip
obj62 différents états
(16.49 Kio) Téléchargé 426 fois
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Oukcha
RespOOnsable modération
RespOOnsable modération
Messages : 3488
Inscription : 06 oct. 2008 10:03

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Oukcha »

Bonjour,
CdChar a écrit :Se passe sous WXP.
Merci de préciser également le Service Pack (actuellement, XPsp3)
Information à renseigner dans votre signature.

Cordialement, Oukcha
                                        
:arrow: A lire avant tout ! Image
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

CdChar a écrit :Un plantage lors de la dernière, m'a fait m'inquiéter du contenu du fichier
Excuse moi mais as-tu lu ce que j'ai écrit plus haut ?
Dude a écrit :Bref, plus rien à voir avec l'extension de sauvegarde d'Alain. Si tu souhaites donc poursuivre le débat, ouvre un nouveau fil dans la section Base.
CdChar a écrit :Entre temps, j'avais modifier la taille du cache
Et redémarré OOo bien sûr en vérifiant que le démarrage rapide ne soit pas activé ?
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,

Windows XP SP3.
J'ai posté ici parce que j'ai pensé à un effet de bord de l'extension.
Merci
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

CdChar a écrit :J'ai posté ici parce que j'ai pensé à un effet de bord de l'extension.
Pour en être sûr, il faudrait que tu désactives l'extension et que tu fasses tes opérations de sauvegarde à la main.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,
C'est en effet l'option que j'ai prise depuis hier, dans le doute.
Je ferai de même pour une autre, mais ce n'est pas le sujet ici.
Merci pour ta réactivité.
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,
Je joins à ce message un fichier contenant une base simple ( 1 table + 1 formulaire, à peine 10 lignes de données) ainsi que l'image d'un des messages d'erreur que je reçois.
Pour reproduire le problème:

1 ) ouvrir la base en double cliquant sur le fichier dans un navigateur ( mode d'ouverture initial probablement sans importance)
2 ) ouvrir le formulaire pour modification
3 ) modifier le formulaire
4 ) enregistrer le formulaire
5 ) enregistrer la base
6 ) fermer la base
7 ) NE PAS FERMER LA PAGE D'ACCUEIL de OOO
8 ) ouvrir la base en passant par la page d'accueil: "Base de données" ---> "Ouvrir un fichier de base de données existant"
9 ) faire immédiatement une sauvegarde auto

Variantes: ouvrir le formulaire pour saisir des données, ouvrir la base en double-cliquant sur le fichier dans le navigateur Windows, mais sans jamais fermer la page d'accueil de OOO

Pour info j'ai détruit une base de test en faisant exactement les mêmes manipulations avec SWITCHBOARD seul ( sans faire de sauvegarde automatique) et les corruptions de fichiers dont je parlais précédemment viennent sans doute de là.

W7 et WXP SP3

Est-ce ici qu'il fallait signaler le problème, est-ce à un niveau plus général, je ne sais, merci pour votre indulgence en cas d'erreur.
Merci pour votre temps
Pièces jointes
testsvg.zip
une base + une image
(111.11 Kio) Téléchargé 437 fois
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 23853
Inscription : 03 mars 2006 09:45
Localisation : 127.0.0.1
Contact :

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Dude »

Juste une précision dans ta procédure, j'ai ajouté un 4bis fermer le formulaire. L'as-tu fait aussi ?
Maintenant, quel est l'intérêt de faire une sauvegarde à l'ouverture d'une base non modifiée. La sauvegarde auto si elle doit être faite, est à exécuter après modification.
CdChar a écrit :Pour info j'ai détruit une base de test en faisant exactement les mêmes manipulations avec SWITCHBOARD seul ( sans faire de sauvegarde automatique) et les corruptions de fichiers dont je parlais précédemment viennent sans doute de là.
En tout cas, je n'ai pas l'extension SwitchBoard et je n'ai pu reproduire cette bogue.
CdChar a écrit :Est-ce ici qu'il fallait signaler le problème
Non, tu es sur un forum d'utilisateurs bénévoles. Il n'y a aucune personne du développement ici pour te répondre. Si effectivement SwitchBoard est en cause, il faut contacter l'auteur directement.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour,
Un reflex vieux d'un certain nombre d'années, avant toute modification à un fichier auquel je tiens, je le sauvegarde, ce qui ne m'empêche pas de le faire également pendant et après, prudence, prudence....

D'ailleurs si je fais la sauvegarde auto après avoir ajouté une ligne dans la table en utilisant le formulaire, puis le fermant, j'ai aussi le problème.
Le tout c'est que la fenêtre qui contient le menu suivant soit ouverte.
ooo.jpg
Je ne choisis pas d'ouvrir cette fenêtre, le démarrage rapide n'est pas activé, j'ouvre mes fichiers à partir du navigateur Windows par double-clic. Jusque là je peux faire autant de sauvegardes que je veux, mais quand je ferme la base par l' option "Fermer" du menu "Fichier" cette fenêtre s'ouvre, c'est alors le début de mes problèmes si j'ouvre à nouveau mon fichier par double-clic ou en passant par l'option "Base de données" de cette page.
Évidemment, je peux la fermer ou utiliser l'option "Quitter" .

Dans la base attachée précedemment (testsvg.zip), SWITCHBOARD n'est pas activé, j'ai refait un test en le désactivant de OOO, le problème est le même.
Exception
Exception
Si je suis la seule à avoir ce problème, n'y passons pas plus de temps, mais je n'ai vraiment pas de chance, car je le reproduis sur 3 machines différentes ( XP et W7), avec un historique différent des installations de OOO.
Cordialement
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Grenouille
ManitOOu
ManitOOu
Messages : 3223
Inscription : 13 janv. 2006 18:21
Localisation : Chasseneuil-du-Poitou / Futuroscope

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Grenouille »

Bonjour,
CdChar a écrit :Un reflex vieux d'un certain nombre d'années, avant toute modification à un fichier auquel je tiens, je le sauvegarde
Oui sauf qu'avec OOo, le menu ou le bouton "Enregsitrer" ne s'active qu'en cas de modification.

:D
OpenOffice 4.1.5 et LibreOffice 5.3.4 (par obligation) sous Windows 7
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Bonjour Grenouille,
Désolée de ne pas avoir été claire, quand je parle de sauvegarde, ici, il s'agit d'une copie de fichier pour pouvoir revenir en arrière au cas de problème, donc pas sur lui-même .
Cordialement
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
Messages : 11276
Inscription : 02 mai 2006 10:42

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Pierre-Yves Samyn »

Bopnjour
CdChar a écrit :Si je suis la seule à avoir ce problème, n'y passons pas plus de temps, mais je n'ai vraiment pas de chance, car je le reproduis sur 3 machines différentes ( XP et W7), avec un historique différent des installations de OOO.
Tu n'es pas la seule et le problème se reproduit facilement grâce à ta parfaite description...

Le problème vient de la mise à jour du "raccourci" thiscomponent dans ce contexte. Pour le résoudre il faut modifier le code de l'extension pour utiliser systématiquement :

Code : Tout sélectionner

oDoc = StarDesktop.currentComponent
CdChar
Membre lOOyal
Membre lOOyal
Messages : 44
Inscription : 30 sept. 2009 08:00

Re: [OXT] sauvegarde auto avec incrément du nom

Message par CdChar »

Merci Pierre-Yves.
Apache OpenOffice 4.1.0 et LibreOffice 4.2.6.3
Java 1.7.0_65
Windows7
Avatar de l’utilisateur
Alain de La Chaume
HédOOniste
HédOOniste
Messages : 1527
Inscription : 28 sept. 2008 14:56
Localisation : ʇsǝnoo,ꞁ ɐ ʇuǝɯǝʇǝꞁdɯoↃ

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Alain de La Chaume »

Bonjour à tous

J'ai reçu un message privé dont voici un extrait :
Franc49 a écrit :Je voudrais te proposer pour incrsav de ne plus afficher automatiquement le message "document sauvegardé sous" car on comprend bien vite le fonctionnement pour le chemin de la sauvegarde.
Merci beaucoup pour cette extension très utile !
J'y apporte une réponse publique pour le cas où d'autres utilisateurs ne connaissant pas les macros seraient intéressés par cette petite modification.

1. Editer la macro
Menu Outils > Macros > Gérer les macros > OpenOffice.org Basic... (ou Alt-F11)
Dans la liste "Macro de" sélectionner incrSav puis aMain
Dans la liste "Macros existantes dans : aMain" sélectionner acIncrementSave_v104 puis cliquer sur bouton Editer
(_v104 pour la version 1.0.4, donc variable)

2. Chercher ce code

Code : Tout sélectionner

	msgBox("Document sauvegardé sous " & cr _
		 & acDecoupePath(convertFromUrl(sUrl2), 50)
3. Le neutraliser ainsi

Code : Tout sélectionner

'	msgBox("Document sauvegardé sous " & cr _
'		 & acDecoupePath(convertFromUrl(sUrl2), 50)
ou le supprimer purement et simplement... C'est vous qui voyez. :wink:
(API-culteur et pêcheur de macros en mode loisirs occasionnels, mais toujours les pieds dans l'OO)
AOO 4.1.2 sous Linux Xubuntu Voyager 14.04 (x86_64)
Franc49
Membre OOrganisé
Membre OOrganisé
Messages : 80
Inscription : 27 oct. 2010 18:50

Re: [OXT] sauvegarde auto avec incrément du nom

Message par Franc49 »

Oui, merci beaucoup Alain.

J'ai bien compris mais je n'arrive pas à modifier la macro. Elle est comme protégée en écriture.
Je tape correctement le ' par exemple mais rien ne change dans le texte de la macro.

Merci.
OpenOffice 4.? sous Windows 7
Répondre