[Solved] Cannot install the Language Tool extension

Discussions about using 3rd party extension with OpenOffice.org
Post Reply
SJCAdmin
Posts: 2
Joined: Mon Nov 16, 2009 10:55 pm

[Solved] Cannot install the Language Tool extension

Post by SJCAdmin »

All,

I am trying to install the Language Tool Extension 1.0.0 on Oo.o 3.1 and Windows XP Pro SP3. The instructions say to 'Double-click LanguageTool-1.0.0.oxt'. Problem is there is no 'LanguageTool-1.0.0.oxt' in the distro. The alternative solution is to 'call Tools -> Extension Manager -> Add... in OpenOffice.org and browse for the LanguageTool-1.0.0.oxt file'. Again, no 'LanguageTool-1.0.0.oxt' in the distro. The distro I am using was downloaded from languagetool.org. I even tried to download several older versions and still no 'LanguageTool-1.0.0.oxt file'.

What (oh OpenOffice lords) am I missing here?

Thank you in advance!!

Michael
Last edited by Hagar Delest on Tue Nov 17, 2009 2:56 pm, edited 1 time in total.
Reason: tagged [Solved].
OpenOffice 3.1 on Windows XP Pro SP3
User avatar
Robert Tucker
Volunteer
Posts: 1250
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Re: Cannot install the Language Tool extension

Post by Robert Tucker »

Go to:

http://extensions.services.openoffice.o ... nguagetool

click on "Get it!" and download it to somewhere you can find it. Install using the extension manager.
LibreOffice 7.x.x on Arch and Fedora.
SJCAdmin
Posts: 2
Joined: Mon Nov 16, 2009 10:55 pm

Re: Cannot install the Language Tool extension

Post by SJCAdmin »

Robert Tucker wrote:Go to:

http://extensions.services.openoffice.o ... nguagetool

click on "Get it!" and download it to somewhere you can find it. Install using the extension manager.
Thank you for the reply. After initially reading your response I said to myself "Wow, Just another link, to the link, to the link, that I already downloaded". :crazy: But after reading a little more carefully I realized what the problem was:

When I download the distro (regardless of the source) it comes to me as a ZIP file 'LanguageTool-1.0.0.ZIP'. Unzipping the archive produces no .OXT file which is what Oo.o needs to install the extension. I don't know why but I thought I would try renaming the .ZIP to .OXT and IT WORKED!

I don't know why I appear to be the only person in the planet having this problem but I am guessing I won't be the last! :super:

Good Luck out there!!

Michael
OpenOffice 3.1 on Windows XP Pro SP3
caraj1491
Posts: 4
Joined: Sat Aug 19, 2017 9:48 pm

Re: Cannot use the installed the Language Tool extension

Post by caraj1491 »

I got the extension downloaded. Tools-/Extension Manager says it is installed and added. I am in the middle of a long transcription in Writer and really need the help but cannot find how to invoke Language Tool. Where is it? How do I get it to start working in my document? Thank :D
Open Office 4.1.3 on Windows 10
User avatar
robleyd
Moderator
Posts: 4424
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: [Solved] Cannot install the Language Tool extension

Post by robleyd »

Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 15 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 15 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
esperantisto
Volunteer
Posts: 558
Joined: Mon Oct 08, 2007 1:31 am

Re: [Solved] Cannot install the Language Tool extension

Post by esperantisto »

LanguageTool should work immediately. Or hit Shift + F7 to re-check the document.
AOO 4.2.0 / LibO 6.x/ Win 7 / openSUSE Linux Leap 15.4 (64-bit)
Post Reply