Messing up languages by switching keyboard

Discuss the word processor
Post Reply
Posts: 1
Joined: Sat Oct 24, 2009 8:47 am

Messing up languages by switching keyboard

Post by atalsen »

Dear All,
I love to use OOo but I realized I have a problem with the new versions (from 3.0).
I need to insert text form many different ancient languages that need particular characters, sometimes I have to insert ancient greek text.
I use, as input layout keyboard, the German (Swiss) KBD because is the most useful one if oyu have to insert many chars with diacritics (as I do).
Now, I also make estenisve use of styles in OOo Writer and I always set a specific language ofr evey single style (included, which is much important for me, the [none] option). When I need to insert text in acnient greek I just chenge my keyboard layout to greek (polytonic), then I switch back to my default German (Swiss) layout.
My problem is this: As soon as I change the KBD layout while writing a document, the language of the system KBD will overwrite sistematically the language set in the OOo style options. For istance: I start writing with the German Swiss KBD using a paragraph style set with English and everything is fine, then I change the KBD to Greek, insert a Greek charahcter, maybe a single letter, go back to the German Swiss KBD, still using the style set in Englis but the language changes automatically to German!! And I have not found a way out of this a part from setting in the system a KBD with input language English and KBD layout German Swiss :crazy:
Why OOo Writer allow the system language connected to the keyboard layout to overwrite the internal setting of the paragraph/character style? Does anyohe have some ideas?
Thans anyway! :)

Title Edited. A descriptive title for posts helps others who are searching for solutions and increases the chances of a reply (Hagar, Moderator).
OOo 3.1.1 WIN
User avatar
Posts: 540
Joined: Wed Nov 12, 2008 9:25 pm
Location: FRA 'n' QXB

Re: messing up languagues

Post by franx »


still not a solution - but for a better understanding of the problem →

- Software Specification Document - Writer - Set Language Attribute for Text ... r_Text.odt
Chapter 1.5 (p. 11) - Set Text Language to Input Language Automatically (Windows Only, i1035)
Illustration 14 (p. 16) - Input language sets text language by default on Windows systems

- Issue 1035: language setting for typed text should be set to current input locale (keyboard setting)
- Issue 91552: Input language detection leads to unwanted text language switch
- Issue 100762: Different languages with one keyboard layout aren't possible

- (some remarks in German, 2009-01-03: [de users] Koppelung der Rechtschreibung an Tastatursprache? )

LibreOffice 4.0.4 · WinXP
User avatar
Robert Tucker
Posts: 1250
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Re: messing up languagues

Post by Robert Tucker »

If the second language you are working with is Ancient Greek, then perhaps Thessalonica will provide a solution, since you won't need to change keyboard to insert a Greek character.

[Just for the record, I don't think the problem you describe occurs using Linux/Gnome.]
LibreOffice 7.x.x on Arch and Fedora.
Post Reply