[Solved] Netebans 6.1,OO3.0. OSX and the OO plugin?

Creating a macro - Writing a Script - Using the API
Post Reply
jeffpk
Posts: 18
Joined: Fri Oct 31, 2008 5:43 pm

[Solved] Netebans 6.1,OO3.0. OSX and the OO plugin?

Post by jeffpk »

Hi Guys,

I'm trying to get the Netbeans plugin working for OO 3.0 development on Max OSX 10.5

I have teh plug-in installed, and its seems happy when I point it at my OO install and my SDK install HOWEVER...

When i generate a project, the OO Library it has in its libraries consists of a set of references to non-existant Jar files.
(It thinks they exists under <OO app>/programs/ first off, on the mac that woudl be <OO app>/contents/link-base/programs and secondly even in that directory not all of the jars are present.)

Has anyone gotten the NB plugin working on mac OSX? if so can you pls tell me how??

Thanks

JK
Last edited by jeffpk on Sat Nov 01, 2008 5:27 am, edited 3 times in total.
OOo 3.0.X on Mac OSx Leopard
jeffpk
Posts: 18
Joined: Fri Oct 31, 2008 5:43 pm

Re: netebans 6.1, OO 3.0. OSX and the OO plugin?

Post by jeffpk »

Okay, i fixed it.

The OpenOffice library the plug-in installs is wrong for mac OSX. The proper Jar directories are /Applications/OpenOffice.org.app/Contents/basis-link/ure-link/share/java and /Applications/OpenOffice.org.app/Contents/basis-link/program/classes

HOWEVER Netbeans gets confused by the mac idea of an "app" being a dirtectory tree and wont let you open OpenOffice.org.app in the library jar files dialog.

What I did was to create a symlink called "basis-link" in my SDk folder that links to /Applications/OpenOffice.org.app/Contents/basis-link. I could then assign the Jars through that link.
OOo 3.0.X on Mac OSx Leopard
jeffpk
Posts: 18
Joined: Fri Oct 31, 2008 5:43 pm

Re: [NOT QUITE SOLVED]netebans 6.1,OO3.0. OSX and the OO plugin?

Post by jeffpk »

Well, its ALMOST solved...

It builds the sample skeleton app fine, but when I try to run it it generates this error:

com.sun.star.lib.loader.Loader::getCustomLoader: exec unoinfo: java.io.IOException: Cannot run program "${office.program.dir}/unoinfo": error=2, No such file or directory
com.sun.star.comp.helper.BootstrapException: no office executable found!
at com.sun.star.comp.helper.Bootstrap.bootstrap(Bootstrap.java:248)
at com.example.OfficeUNOClientApp3.main(OfficeUNOClientApp3.java:29)

(etc)

I'm out of idea at this point. Does anyone know how to fix this?
OOo 3.0.X on Mac OSx Leopard
jeffpk
Posts: 18
Joined: Fri Oct 31, 2008 5:43 pm

Re: [SOLVED]netebans 6.1,OO3.0. OSX and the OO plugin?

Post by jeffpk »

Alright, I found it.

It was in build-uno-impl.xml

I went in and repalced the variable with my hardcoded path to the OO3 executable. Not elegant, but it works
OOo 3.0.X on Mac OSx Leopard
Post Reply