Java Defective Help!

Issues with installing under all versions of MS Windows
Post Reply
Pegasus
Posts: 4
Joined: Wed Jun 27, 2012 4:17 am

Java Defective Help!

Post by Pegasus »

I have recently installed OpenOffice 3.4. I am getting the following popup whenever I attempt to open a table, form, etc in Base: "OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java."

I have Windows Vista and the most recent Java 7.5. I have not only uninstalled and reinstalled java and have restarted my laptop and it still does not work and says the same thing...please help..I have had older versions on my laptop, however after a hard drive crash and a fix..I lost my Open Office..now a new one won't work.
Open Office 3.4 Windows Vista
FJCC
Moderator
Posts: 8712
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: Java Defective Help!

Post by FJCC »

Apache OpenOffice doesn't like the 7 series of Java. Try using the latest of the 6 series, which is 1.6.31, I think.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
Pegasus
Posts: 4
Joined: Wed Jun 27, 2012 4:17 am

Re: Java Defective Help!

Post by Pegasus »

Ok Thanks Sorry for multiposting...this is my first time here and wanted to make sure it went in the right area. Ok, so when I go to Java it says I'm up to date..so do I have to uninstall the new one? And how do I get an older version? Also wouldn't an older version affect the things that I need the newer version for? Very confusing...wouldn't the developers make it compatible to new versions of Java and keep up to date? Like with a patch or so?
Open Office 3.4 Windows Vista
Pegasus
Posts: 4
Joined: Wed Jun 27, 2012 4:17 am

Re: Java Defective Help!

Post by Pegasus »

Ok apparently the older version of Java Version 6 Update 33 is the latest before 7. However it only has downloads for Windows 7 and XP not Vista. Also perhaps you have older versions of Open Office that does accept series 7? If not..do you know of any programs similiar to this as I need one right away.
Open Office 3.4 Windows Vista
thomasjk
Volunteer
Posts: 4447
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Java Defective Help!

Post by thomasjk »

If it works on XP and Win 7 it will also work with Vista. Do you really think they skipped a generation of Windows?
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
PGAGA
Volunteer
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: Java Defective Help!

Post by PGAGA »

Wednesday, June 27, 2012

To make life interesting there are three Java versions in contemporaneous development.

Java 6 now at 33
Java 7 now at 5
Java 8 only in development release

All tend to be updated at the same time.

For use with OOo need to have then 32 bit version of Java 6 installed. The others can be on you system but will not work with OOo.

Phil
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
User avatar
Hagar Delest
Moderator
Posts: 30971
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Java Defective Help!

Post by Hagar Delest »

PGAGA wrote:For use with OOo need to have then 32 bit version of Java
That is the point I think. Pegasus, make sure that you have the 32bit version instead of the default 64bit version if your machine runs on 64bit.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
LibreOffice 7.4 on Xubuntu 22.10 and 7.4 portable on Windows 10
User avatar
RoryOF
Moderator
Posts: 33787
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Java Defective Help!

Post by RoryOF »

You can download a 32 bit Java from
Source for 32 bit Java

Having installed this, you need to start OpenOffice and go to /Tools /Options /OpenOffice.org : Java, wait for a few seconds until it identifies the Java installations and check the box beside this 32 bit Java. I can't remember if one needs to restart OpenOffice or not, including the Quickstarter, but it won't hurt. I would normally close down the computer (power off) and restart [old habits from Windows 3 days].
Apache OpenOffice 4.1.13 on Xubuntu 22.04.1 LTS and very infrequently on Win2K/XP
Bill
Volunteer
Posts: 8722
Joined: Sat Nov 24, 2007 6:48 am

Re: Java Defective Help!

Post by Bill »

Pegasus wrote:Ok apparently the older version of Java Version 6 Update 33 is the latest before 7. However it only has downloads for Windows 7 and XP not Vista.
I see a link "Which should I choose" on the Java Downloads page. That link opens a page showing the system requirements. Vista is listed there.
rozwalts
Posts: 2
Joined: Wed Jul 04, 2012 10:08 am

Solved Java Defective Help!

Post by rozwalts »

Bill wrote:
Pegasus wrote:Ok apparently the older version of Java Version 6 Update 33 is the latest before 7. However it only has downloads for Windows 7 and XP not Vista.
I see a link "Which should I choose" on the Java Downloads page. That link opens a page showing the system requirements. Vista is listed there.
Many thanks Rory. I think I am now up and running, just wondering for how long!

Ok maybe I am being stupid, but although Vista is listed for the Windows downloads it does not say anything about 32 bit. I tried downloading it from where the Windows downloads are, I have clickled on the relevant bit in Open Office, but I am still getting the sdame error message.

On reflection perhaps it isn't me who is stupid, but the idiots who came up with two updates which are not compatible with each other. In all the years I have used computers, which is round about 25, I have never had this problem before.
Last edited by rozwalts on Wed Jul 04, 2012 12:50 pm, edited 2 times in total.
OpenOffice 4.12 on Windows 8
rozwalts
Posts: 2
Joined: Wed Jul 04, 2012 10:08 am

Solved Java Defective Help!

Post by rozwalts »

Can somebody please post an exact link for version 6, 32 bit for Vista? I have gone round and round in circles and cannot find it. I am getting so seriously fed up I am thinking of going back to Word. That shows how desperate I am.
Last edited by rozwalts on Wed Jul 04, 2012 3:24 pm, edited 1 time in total.
OpenOffice 4.12 on Windows 8
User avatar
RoryOF
Moderator
Posts: 33787
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Java Defective Help!

Post by RoryOF »

I've been rooting around on the Java site, and it is frustrating.

Try this
http://www.filehorse.com/download-java-runtime-32/9827/

I haven't tried it, but it looks OK.
Apache OpenOffice 4.1.13 on Xubuntu 22.04.1 LTS and very infrequently on Win2K/XP
PGAGA
Volunteer
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: Java Defective Help!

Post by PGAGA »

Wednesday, July 04, 2012

This is the site with the latest downloads for 6 and 7.

http://www.oracle.com/technetwork/java/ ... #javasejdk

For 32 bit for vista, go here (a link from the above)

http://www.oracle.com/technetwork/java/ ... 37595.html

and download the x86 version. The 64 bit version is tagged x64.

Phil
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
rozerben
Posts: 1
Joined: Tue Feb 19, 2013 2:16 pm

Re: Java Defective Help!

Post by rozerben »

RoryOF wrote:I've been rooting around on the Java site, and it is frustrating.

Try this
http://www.filehorse.com/download-java-runtime-32/9827/

I haven't tried it, but it looks OK.

i m re-install the java software .
OpenOffice 3.1 on Windows Vista
Bill
Volunteer
Posts: 8722
Joined: Sat Nov 24, 2007 6:48 am

Re: Java Defective Help!

Post by Bill »

@rozerben: The original link you copied goes to a site where Java can be downloaded. The modified link you posted does not. What's the connection between your link and Java? How does it contribute to this topic?
AOO 4.1.10 on Ubuntu MATE 21.04
User avatar
RoryOF
Moderator
Posts: 33787
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Java Defective Help!

Post by RoryOF »

I've corrected the link in rozerben's posting, which link may have been munged in error. The quoted link is now correct.
Apache OpenOffice 4.1.13 on Xubuntu 22.04.1 LTS and very infrequently on Win2K/XP
Post Reply