Keyboard problem

Issues with installing under all versions of MS Windows
Post Reply
Harvey Schneider
Posts: 1
Joined: Sat Mar 27, 2010 8:52 pm

Keyboard problem

Post by Harvey Schneider »

I get wrong upper case characters (for many) when using open office vs. excel.

I hope there is a simple solution.
| ! ” / $ % ? & * ( ) _ + --- Produced when top row upper case keys are punched (Open Office spread sheet or text document).

~!@#$%^&*()_+ -- Produced (correctly) when Excel is used. Please assist.
Posts: 651
Joined: Mon Mar 09, 2009 1:12 am
Location: Galiza (España)

Re: Keyboard problem

Post by mriosv »

What happen in other third program?
LibreOffice 3.5.4 AOo-3.4 on Win 7 Ultimate
Posts: 30
Joined: Thu Sep 25, 2008 4:45 am

Re: Keyboard problem

Post by mgagnonlv »

Check the icons in your language bar. I suspect that you have a different keyboard selected for OpenOffice vs Excel, either because you did not select the proper one or because you "automatically switched" keyboards. Vista and XP have a bug with regard to language and keyboard selection, and to solve it, do the following.
Note. Check for proper menus, as I have both XP and System 7 in French and don't have a Vista in front of me to check it.

1. Close all programs.
2. Open Control Panels, then either "Regional and Linguistic Options" or something like that.
3. Select the tab "Languages". In XP, you need to push on "Details", whereas on Windows 7, the options are right there.
4. Select the Language you want and the keyboard you want.
5. Very important : Make those as default and apply them to the system (otherwise your choices won't always be used)
6. Click on "Key Parameters" (or something along that line); in the window that opens, make sure that NO key combinations are available to switch either between keyboards or languages.
7. Save and close everything. You should be OK now.
Michel Gagnon
OOo 3.2.1 on Windows XP and on Windows 7.
Post Reply