[Solved] Date field changing

Discuss the database features
Post Reply
Georged55
Posts: 9
Joined: Wed Jun 03, 2009 11:43 pm

[Solved] Date field changing

Post by Georged55 »

I created an OO data base on 11/13/2005, yes, almost 15 years ago, and have used it every day since as a journal to keep my daily activities. Today is 1/1/2021 & the date will not change. When I set the date field to 1/1/21 it immediately sets itself back to 12/31/20. Is there something in OO that restricts the maximum date in any way? I can't find anything. Is there something I can do to fix this? :?:
 Edit: Split from Maximum Size of a Base Database as the problem is unrelated.
Please start a new topic for a new problem.
 
Last edited by robleyd on Fri Jan 08, 2021 2:15 am, edited 2 times in total.
Reason: Add green tick
OOo 3.1.X on Ms Windows XP
FKlusmann
Posts: 43
Joined: Fri Jan 20, 2017 3:22 am

Re: Maximum Size of a Base Database

Post by FKlusmann »

Happy New Year, @Georged55!
I ran across this while looking for something else. Try, from the main Base panel, <Tools> <Options> [Oo or LibreOffice][General] and under "Year (Two Digits)", change the range to a higher value.
Thank you ALL! (Win 10 - LibreOffice Version: 7.0.3.1 (x64))
Saving the Planet! Only recycled electrons were used in this post!
User avatar
Villeroy
Volunteer
Posts: 30799
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Maximum Size of a Base Database

Post by Villeroy »

FKlusmann wrote:Happy New Year, @Georged55!
I ran across this while looking for something else. Try, from the main Base panel, <Tools> <Options> [Oo or LibreOffice][General] and under "Year (Two Digits)", change the range to a higher value.
By default this setting is 1930. This is the setting which determines if 1/1/30 is meant to be in 2030 or 1930. It does not impose any limit to the entered date.
Georged55 wrote:When I set the date field to 1/1/21 it immediately sets itself back to 12/31/20. Is there something in OO that restricts the maximum date in any way? I can't find anything. Is there something I can do to fix this?
This happens in your input form only, I think. You defined a maximum date for the form control.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
Georged55
Posts: 9
Joined: Wed Jun 03, 2009 11:43 pm

Re: Date field changing

Post by Georged55 »

I can't find anyplace where the maximum date can be changed or specified. I increased the value under Year (two digits) to between 2000 and 2099 and nothing changed. Can anyone specify exactly what I have to do to possible change the maximum date setting. I can't find anything.
OOo 3.1.X on Ms Windows XP
User avatar
Villeroy
Volunteer
Posts: 30799
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Date field changing

Post by Villeroy »

Open the form for editing and get the properties dialogue of the date control.
And test if you can enter a record with a recent date directly into the table.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
Georged55
Posts: 9
Joined: Wed Jun 03, 2009 11:43 pm

Re: Date field changing

Post by Georged55 »

First thanks for your assistance with this.
I guess there's a lot I don't know including how I created this in the first place back in 2005. I don't know how to open the form for editing so can't get the properties dialogue of the date control. Do I open the .odb file? I open that, select Forms, right click on the file in the Forms section & select Edit. This opens my form. I right click on the Date block but there's no properties in the list. I'm quite confused.
OOo 3.1.X on Ms Windows XP
User avatar
Villeroy
Volunteer
Posts: 30799
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Date field changing

Post by Villeroy »

No problem. You have opened the form for editing. Now there are 2 glitches:
1) When you click on the date control it may be selected together with its label (if any) because the 2 elements may be grouped. Use Ctrl+Click to select a single element regardless of grouping.
2) Right-click>Control... calls the control's properties dialog whereas right-click>Form... calls the properties dialog for the control's logical form (the data connection to some table or query).
Two of the date control's properties are min.date and max. date. Change them, close and save the form, save the containing database document. There are other ways to impose limits on date input but this is the most likely one.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04 with LibreOffice 6.0, latest OpenOffice and LibreOffice
Georged55
Posts: 9
Joined: Wed Jun 03, 2009 11:43 pm

Re: Date field changing

Post by Georged55 »

Great answer. Was able to locate Date properties. Thanks for helping.
OOo 3.1.X on Ms Windows XP
Post Reply