[Solved] OOo v3.1 Draw is Really slow now

Discuss the drawing application
Post Reply
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

[Solved] OOo v3.1 Draw is Really slow now

Post by roadbike »

Anyone know what is up with OOo v3.1 Draw being so slow? It takes so unbearably long to do anything in Draw now that it's almost unusable. Is this issue related to anti-aliasing? I didn't have any problems using Draw in OOo v3.0. Someone else has also posted about this issue in the other forum, so I suspect that more people are having this issue.

:cry:
Last edited by roadbike on Wed Jun 10, 2009 6:52 pm, edited 5 times in total.
OOo 3.1.X on Ms Windows XP
User avatar
Hagar Delest
Moderator
Posts: 30662
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by Hagar Delest »

Have you tried to reset your OOo user profile. But during the welcome process, don't transfer your personal data (if you had 2.x before), former configuration files might corrupt the new profile.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

Hey Hagar,

I tried that, but things are still slow. :(
OOo 3.1.X on Ms Windows XP
User avatar
Hagar Delest
Moderator
Posts: 30662
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by Hagar Delest »

I don't experience such problem. Does it occur for any document? Even new ones? Any security application that could prevent Draw from running correctly? Have you tried to disable your anti-virus and firewall temporarily?
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

Yes, on three different machines all running XP SP3 and OOo v3.1. All machines have different anti-virus/firewall packages. New documents and old.

No problems with Draw OOo v3.0 on any of the machines.
OOo 3.1.X on Ms Windows XP
User avatar
TheGurkha
Volunteer
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by TheGurkha »

I don't see this on XP.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
ehanuise
Posts: 13
Joined: Wed May 13, 2009 6:27 pm

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by ehanuise »

I have the same problem since I upgraded.
Any document that is the least bit complex becomes unbearably slow.

try opening a couple pictures, then draw some circles and rectangles on it, make some translucent and a gradient or two and it slows down to a crawl for the simplest object moves.

is there any way to disable antialiasing in draw ?
OOo 3.1.X on Ubuntu 8.x
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by acknak »

I noticed this today also, working with a document that uses a background gradient. Moving objects over the gradient is much more slow than previous versions of Draw. I wouldn't call it "unusable" but definitely noticeable and distracting.

Draw has always been slower as you increase the zoom, and now that difference is even greater, so that working at higher zoom levels is quite unpleasant.

I expect this has to do with the new "preview while moving" feature and the new graphics layer code that have recently been introduced. I don't know of any option or workaround for either of those.
AOO4/LO5 • Linux • Fedora 23
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

Hey acknak, I use a gird that is 0.10" square with 5 divisions, and have to do precision placement so that may be why a lot of people haven't noticed it yet.
OOo 3.1.X on Ms Windows XP
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by acknak »

So you must be working at a high zoom to be able to see a difference of 0.02" -- right?
AOO4/LO5 • Linux • Fedora 23
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

Yep.
OOo 3.1.X on Ms Windows XP
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by acknak »

I would consider filing a bug report. [Tutorial] Reporting bugs or suggestions

Here's a search of performance issues with activity in the last 90 days: Issuezilla search. It looks like a lot of improvements are due to appear in the next two major releases (3.1/3.2).

If none of those seem to address the problem you're seeing, then file a new one.
AOO4/LO5 • Linux • Fedora 23
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

There are quite a few issues there. I'll just roll with it.....two steps forward and 1/2 a step back. Things get better over time, so no doubt these issues will be addressed eventually.
OOo 3.1.X on Ms Windows XP
ehanuise
Posts: 13
Joined: Wed May 13, 2009 6:27 pm

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by ehanuise »

I eventually emailed armin legrand, who provided me with the following info :

- antialiasing can be disabled in tools/options/view/enable antialiasing
- 'full drag' can be disabled in view/toolbars/options (last to next item)

However this ain't the cause of the slowness :p it's because somehow hardware acceleration of the rendering was not enabled.
Xrender acceleration must be present on the system and enabled in your X server (option "RenderAccel" in Nvidia xorg server), and you must use an OoO build that has hardware acceleration enabled (not grayed out in tools/options/view/hardware acceleration).
Apparently this ain't the case with the http://www.openoffice.org .debs :
http://user.services.openoffice.org/en/ ... 10&t=13180

The openoffice.org-ogltrans package may also help with slow impress transitions :)
OOo 3.1.X on Ubuntu 8.x
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by acknak »

Nice! Thanks for passing that along.
- 'full drag' can be disabled in view/toolbars/options (last to next item)
Eh? I don't see that menu path.
AOO4/LO5 • Linux • Fedora 23
ehanuise
Posts: 13
Joined: Wed May 13, 2009 6:27 pm

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by ehanuise »

Well, you should so it's a bit odd :/
OOo 3.1.X on Ubuntu 8.x
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

I don't see that menu path either. Also on TOOLS>OPTIONS>OpenOffice.org>VIEW-GRAPHICS OUTPUT has both USE HARDWARE ACCELERATION & USE ANTI-ALIASING checked.
User avatar
chubble10
Posts: 17
Joined: Sun May 17, 2009 4:09 pm
Location: Bromsgrove

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by chubble10 »

I don't see that path either (see pic - link:http://www.filefactory.com/file/ag0f20d ... 75363_jpeg)!
Flock - The Social Web Browser
OOo 3.1.X on MS Windows Vista + Ubuntu Linux (Beta)
User avatar
Hagar Delest
Moderator
Posts: 30662
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by Hagar Delest »

chubble10 wrote:I don't see that path either (see pic - link:http://www.filefactory.com/file/ag0f20d ... 75363_jpeg)!
Can't you upload the screenshot here (see here: How to attach a document here)? I can't see your file.

It seems to be the paintbrush icon (Modify Object with Attributes).

Edit: uploaded screenshot
Options.png
Options.png (7.28 KiB) Viewed 20755 times
LibreOffice 7.2.6 on Xubuntu 22.04 and 7.2.6 portable on Windows 10
ehanuise
Posts: 13
Joined: Wed May 13, 2009 6:27 pm

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by ehanuise »

It's there, in your screenshot : 'Options'.
oootoolbaroptions.jpg
This'll bring you an options toolbar, and the next to last item is the 'full drag' toggle.
OOo 3.1.X on Ubuntu 8.x
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by acknak »

Ahh, ok. Thanks for the picture.

I assumed, since the 'full drag' feature affects the whole suite, that the toggle would be in any application, but I see now that the toggle is only available in Draw and Impress.

Odd, the tooltip on that button says "Modify Object with Attributes".
AOO4/LO5 • Linux • Fedora 23
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: OOo v3.1 Draw is REEEAAAALLLLYYY slow now.

Post by roadbike »

*scratches head*

Ummm.....ya.....I don't get it either..... "Modify Object with Attributes".....seems to work though.....
OOo 3.1.X on Ms Windows XP
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: [Solved] OOo v3.1 Draw is REEEAAAALLLLYYY slow now

Post by roadbike »

Hey Acknak,

The grid is a part of the problem that I'm having. If i turn the grid off I don't have any problems with zooming, transparent drag or moving objects in general. Turn it on and performance takes a very noticeable dive.
OOo 3.1.X on Ms Windows XP
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] OOo v3.1 Draw is REEEAAAALLLLYYY slow now

Post by acknak »

Interesting.

I'm sure there must be more calculation needed when "snap to grid" is on, but I can't really tell just moving things around in the drawing.
AOO4/LO5 • Linux • Fedora 23
roadbike
Posts: 30
Joined: Tue May 12, 2009 5:40 am

Re: [Solved] OOo v3.1 Draw is REEEAAAALLLLYYY slow now

Post by roadbike »

It's not when "Snap to Grid" is on.....just when "Display Grid" is on.
OOo 3.1.X on Ms Windows XP
User avatar
acknak
Moderator
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] OOo v3.1 Draw is Really slow now

Post by acknak »

Sorry, I still don't see a significant slowdown when the grid is shown.

However, I do see that the grid itself has been drastically improved: the major divisions are now shown as little "+"s and the minor divs are single pixels.

Maybe the more complex grid is slower in some cases.
AOO4/LO5 • Linux • Fedora 23
ias
Posts: 9
Joined: Tue Jan 20, 2009 6:51 pm

Re: [Solved] OOo v3.1 Draw is Really slow now

Post by ias »

Even with all the changes recommended, at least under xp, it is still very very slow. Why is this declared Solved?
OOo 3.1.0 on XP and/or Ubuntu
User avatar
TheGurkha
Volunteer
Posts: 6482
Joined: Thu Mar 13, 2008 12:13 pm
Location: North Wales, UK.

Re: [Solved] OOo v3.1 Draw is Really slow now

Post by TheGurkha »

ias wrote:Even with all the changes recommended, at least under xp, it is still very very slow. Why is this declared Solved?
The original poster who started the thread set it to be Solved, because for him, it is. If you have a different issue you need to start a new thread. Very few are going to bother with a new post tagged at the back of a thread marked Solved.
Ubuntu 14.10 Utopic Unicorn, LibreOffice Version: 4.3.3.2
Gurkha Welfare Trust
ias
Posts: 9
Joined: Tue Jan 20, 2009 6:51 pm

Re: [Solved] OOo v3.1 Draw is Really slow now

Post by ias »

TheGurkha wrote:
ias wrote:Even with all the changes recommended, at least under xp, it is still very very slow. Why is this declared Solved?
The original poster who started the thread set it to be Solved, because for him, it is. If you have a different issue you need to start a new thread. Very few are going to bother with a new post tagged at the back of a thread marked Solved.
Thanks. I will.
OOo 3.1.0 on XP and/or Ubuntu
davagui
Posts: 1
Joined: Fri Jan 29, 2010 3:02 am

Re: [Solved] OOo v3.1 Draw is Really slow now

Post by davagui »

The problem is the Anti-Aliasing, by deactivating it, everything returned to normal in my OOo Draw, no longer slowed down the whole system to the point to become unusable when zooming-in.

Tools > Options > OOo > View > Use Anti-aliasing.

This is a reported bug: https://bugs.launchpad.net/ubuntu/+sour ... bug/499020
openoffice.org-core 1:3.1.1-5ubuntu1
Linux 2.6.31-17-generic i686
LANG=es_MX.UTF-8
Ubuntu 9.10
Post Reply